URI Online Judge | 1036
Bhaskara's Formula
Adapted by Neilor Tonin, URI Brazil
Timelimit: 1
Read 3 floating-point numbers. After, print the roots of bhaskara’s formula. If it's impossible to calculate the roots because a division by zero or a square root of a negative number, presents the message “Impossivel calcular”.
Input
Read 3 floating-point numbers A, B and C.
Output
Print the result with 5 digits after the decimal point or the message if it is impossible to calculate.
Input Samples | Output Samples |
10.0 20.1 5.1 | R1 = -0.29788 R2 = -1.71212 |
0.0 20.0 5.0 | Impossivel calcular |
10.3 203.0 5.0 | R1 = -0.02466 R2 = -19.68408 |
10.0 3.0 5.0 | Impossivel calcular |
#include<bits/stdc++.h>
using namespace std;
int main()
{
double a,b,c,r1,r2;
cin>>a>>b>>c;
if((b*b-(4*a*c) )<0 || a==0)
{
printf("Impossivel calcular\n");
}
else{
r1=(-b+sqrt(b*b-4*a*c))/(2*a);
r2=(-b-sqrt(b*b-4*a*c))/(2*a);
printf("R1 = %.5lf\n",r1);
printf("R2 = %.5lf\n",r2);
}
}
Comments
Post a Comment