Hashmat the Brave Warrior(URI Online Judge | 1198)

URI Online Judge | 1198

Hashmat the Brave Warrior

By Shahriar Manzoor  Bangladesh
Timelimit: 3
Hashmat is a brave warrior who with his group of young soldiers moves from one place to another to fight against his opponents. Before fighting he just calculates one thing, the difference between his soldier number and the opponent's soldier number. From this difference he decides whether to fight or not. Sometimes Hashmat's soldier number is greater than his opponent.

Input

The input contains two integer numbers in every line. These two numbers in each line denotes the number of soldiers in Hashmat's army and his opponent's army or vice versa. The input numbers are not greater than 232. Input is terminated by End of File.

Output

For each line of input, print the difference of number of soldiers between Hashmat's army and his opponent's army. Each output should be in seperate line.
Input SampleOutput Sample
10 12
10 14
100 200
2
4
100
Solution:

#include<bits/stdc++.h>
using namespace std;
int main()
{
long long int hasmot,opponent,diff;
while(scanf("%lld%lld",&hasmot,&opponent)!=EOF)
{
diff=abs(hasmot-opponent);
printf("%lld\n",diff);
}
}

Comments